Core Platform Degradation

Incident Report for Roadie

Postmortem

On June 7th beginning at approximately 12:25pm EDT, our alerting notified us of a second, unrelated service interruption for our broker service. Underlying cloud network configuration began causing connection timeouts for the broker service. Roadie engineers quickly identified the cause and pushed a fix. Service was fully restored by 12:45pm EDT.

To reduce the likelihood of similar disruptions in the future, we have implemented the following measures:

  • Adjusted workload requests/limits to avoid further resource constraints.
  • Added additional alerting on the affected workloads.

We apologize for any disruption this may have caused. If you have any questions, please feel free to reach out to us at techops@roadie.com.

Posted Jun 10, 2025 - 00:51 EDT

Resolved

Service Disruption Summary – June 7th 2025

On June 7th beginning at approximately 12:25pm EDT, our alerting notified us of a second, unrelated service interruption for our broker service. Underlying cloud network configuration began causing connection timeouts for the broker service. Roadie engineers quickly identified the cause and pushed a fix. Service was fully restored by 12:45pm EDT.

To reduce the likelihood of similar disruptions in the future, we have implemented the following measures:
- Adjusted workload requests/limits to avoid further resource constraints.
- Added additional alerting on the affected workloads.

We apologize for any disruption this may have caused. If you have any questions, please feel free to reach out to us at techops@roadie.com.
Posted Jun 07, 2025 - 12:30 EDT